<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<!--USubChID:::511209--><!--ZZZAPicURLZZZ:::https://images.tmcnet.com/headshots/2012/tmcnet.jpg--><!--ZZZPTitleZZZ:::How Agencies Approach Software Development--><!--ZZZHomepageZZZ:::--><!--ZZZEmailZZZ:::-->





<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head><meta name="description" content="If you decide to outsource the development of the project, you must understand the specifics of this format of cooperation with the agency. You cannot fully control the 'inner kitchen' of the project creation, will it be a startup or software for a large enterprise. But this is not necessary, as experienced agencies ensure the transparency and continuity of all work processes. They maintain constant communication with the client and resolve issues as they become available.">
<meta property="og:image" content="https://images.tmcnet.com/tmc/misc/articles/image/2020-jul/4816640335-bigstock-binary-stream-software-code-developer-tunnel-12115361-supersize.jpg" /><meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>How Agencies Approach Software Development</title>
<meta property="og:title" content="How Agencies Approach Software Development" /><meta name="twitter:title" content="How Agencies Approach Software Development" /><meta property="og:description" content="If you decide to outsource the development of the project, you must understand the specifics of this format of cooperation with the agency. You cannot fully control the 'inner kitchen' of the project creation, will it be a startup or software for a large enterprise. But this is not necessary, as experienced agencies ensure the transparency and continuity of all work processes. They maintain constant communication with the client and resolve issues as they become available." /><meta name="twitter:description" content="If you decide to outsource the development of the project, you must understand the specifics of this format of cooperation with the agency. You cannot fully control the 'inner kitchen' of the project creation, will it be a startup or software for a large enterprise. But this is not necessary, as experienced agencies ensure the transparency and continuity of all work processes. They maintain constant communication with the client and resolve issues as they become available." /><meta property="og:image" content="https://images.tmcnet.com/tmc/misc/articles/image/2020-jul/4816640335-bigstock-binary-stream-software-code-developer-tunnel-12115361-supersize.jpg" /><meta name="twitter:image:src" content="https://images.tmcnet.com/tmc/misc/articles/image/2020-jul/4816640335-bigstock-binary-stream-software-code-developer-tunnel-12115361-supersize.jpg" /><meta name="twitter:card" content="summary_large_image" />

<meta name="keywords" content="Information Technology, InfoTech, IT, Technology News, Tech Information, Application Performance Management, Defrag, Application Performance Monitoring, BPM Software, Cloud Communications,Cloud Computing, Cloud Storage,Data Center Network, Data Center Power, Environmental Montioring, Infrastructure as a Service, Load Balancer, Managed Networks, Network Access, Private Cloud, Projector Lamp, Virtual Tap">
<link rel="stylesheet" href="https://images.tmcnet.com/tmc/vertical/it/style/it.css" type="text/css" />

<style>
.story-article img:first-child { width:100%; height:auto;}
.story-article img:nth-child(2){ width:none; height:none;}
.story-article img:nth-child(3){ width:none; height:none;}
</style>

<script language="JavaScript" src="//images.tmcnet.com/tmc/vertical/techzone/js/techzone.js" type="text/JavaScript"></script>


<script>
document.cookie = "poptmcpop=poptmcpop";
cookieGood = (document.cookie.toString().indexOf("poptmcpop=poptmcpop") >= 0);
if (navigator.cookieEnabled && cookieGood && document.cookie.toString().indexOf("popnow=yes")<0) {

  //************** SPLASH **************//
  location.href="http://it.tmcnet.com/viewette.aspx?u=http%3a%2f%2fit.tmcnet.com%2ftopics%2fit%2farticles%2f2020%2f07%2f24%2f446102-how-agencies-approach-software-development.htm";
}
</script>



<script type="text/javascript" src="https://images.tmcnet.com/js/jquery.js"></script>

</head>
<body>
  


<!--<style>
  .story-article img { 
    width: 500px;
    height: 300px;  
  }
</style>-->


<div id="itech-page-wrap">
<div id="itech-page">
<!-- InfoTech Header -->
<div id="itech-header">
<div class="logo"><a href="http://www.infotechspotlight.com" title="infoTECH Spotlight"><img src="https://images.tmcnet.com/tmc/IT/images/infotech-spotlight.png" alt="infoTECH Spotlight" border="0" /></a></div>
 <!-- Leaderboard -->
<div class="ldr-brd">

<!-- /1003160/zzz -->
<div id='div-x96' style='height:90px; width:728px; text-align:right'></div>
			
</div>
</div>
<div id="tp-nav-nw">
<div class="link-holder">
                <ul id="tmc-temp-menu-horiz">
                    <li><a href="http://it.tmcnet.com/">HOME </a></li>
                    <li><a href="http://it.tmcnet.com/Library.aspx"  title="Information Technology Whitepapers">WHITEPAPERS </a> </li>
                    <li><a href="http://it.tmcnet.com/webinars.aspx" title="Information Technology Webinars">WEBINARS </a></li>
					<li><a href="http://it.tmcnet.com/ebooks.aspx" title="Information Technology eBOOKS">EBOOKS </a></li>
               		<li><a href="http://it.tmcnet.com/Videos.aspx"  title="Information Technology Videos">VIDEOS </a></li>
					<li><a href="http://cloud-computing.tmcnet.com/"  title="Information Technology MAGAZINE" target="_blank">MAGAZINE </a></li>
				    <li><a href="http://it.tmcnet.com/blogs.aspx" title="Information Technology Blogs">BLOGS</a></li>
                    <li><a href="http://it.tmcnet.com/blogs.aspx" title="Information Technology Blogs">NEWS</a>
                     <ul>
					<li><a href="http://it.tmcnet.com/topnews.aspx" title="Information Technology News">Top infoTECH News</a></li>
					<li><a href="http://it.tmcnet.com/itsoftware.aspx" title="Information Technology Software">Software News</a></li>
					<li><a href="http://it.tmcnet.com/ithardware.aspx" title="Information Technology Hardware">Hardware News</a></li>
					<li><a href="http://it.tmcnet.com/itsecurity.aspx" title="Information Technology Security">Security News</a></li>
					<li><a href="http://it.tmcnet.com/itnetworking.aspx" title="Information Technology Networking">Networking News</a></li>
                    </ul>
                    </li>
					<li><a href="http://it.tmcnet.com/Services.aspx" title="Information Technology RESOURCE">RESOURCE </a>
                     <ul>
                    <li><a href="http://it.tmcnet.com/FeaturedArticles.aspx" title="Information Technology Editor's Pick">infoTECH Editor's Pick</a></li>
					<li><a href="http://it.tmcnet.com/Awards.aspx" title="Information Technology Awards">infoTECH Awards</a></li>
					<li><a href="http://it.tmcnet.com/whatshot.aspx" title="What's Hot in Information Technology">What's Hot in Information Technology?</a></li>
					<li><a href="http://it.tmcnet.com/Services.aspx" title="Information Technology Services">infoTECH Services</a></li>
					<li><a href="https://images.tmcnet.com/mkt/media-kit/InfoTECH-Spotlight_Media-Kit.pdf" title="infoTECH Media Kit" target="_blank">infoTECH Media Kit</a></li>
                    </ul>
                    </li>
	     	   </ul>
      </div>
<div class="srch-holder">
<div id="search-holder">
<div class="in">
	<form action="http://it.tmcnet.com/it-search.aspx" id="cse-search-box">
<table width="330" border="0" cellpadding="0" cellspacing="0">
<td width="256" align="right">
<div align="right">
<div class="srch-bkg">
<div id="searchBox">
		<input type="hidden" name="cx" value="009654677570201030784:v1jnvp_r6qo" />
		<input type="hidden" name="cof" value="FORID:9" />
		<input type="hidden" name="ie" value="UTF-8" />
<input name="q" id="q" type="text" value="Type Here to Search" onFocus="this.value='';" class="input-butt"/>
</div>
</div>
</div>
</td>
<td width="80" align="center">
<div id="searchButton">
<input name="sa" onClick="document.cse-search-box.submit()" src="https://images.tmcnet.com/tmc/vertical/it/images/srch_btt_nw.png" type="image" height="20">
</div> </td>
</tr>
</table>
</form></div></div></div></div> 
<div id="itech-main">
<!-- InfoTech Left Nav -->
<div id="itech-left">
<!--<h2 title="Information Technology Online communities"> <a href="http://it.tmcnet.com/communities/" title="Information Technology Communities"> COMMUNITIES <img src="https://images.tmcnet.com/tmc/vertical/it/images/dwn_arrow_it.gif" align="absmiddle" style=" float:right; padding:4px 1px 0px 0px;" border="0" /> </a></h2>
<div id="box135">
<ul id="itechNav-left">
<li class="itech-comm"><a href="http://high-definition-digital.tmcnet.com/" title="High Definition Digital"> High Definition Digital</a></li>
</ul>
</div>-->
<h2><a href="http://it.tmcnet.com/channels/" title="Information Technology Channels"> CHANNELS <img src="https://images.tmcnet.com/tmc/vertical/it/images/dwn_arrow_it.gif" align="absmiddle" style=" float:right; padding:4px 1px 0px 0px;" border="0" /> </a> </h2>
<div id="box135">
<ul id="itechNav-left">

	 
	<li class="itech-comm"><a href="http://www.powerprotectionresource.com/" title="Power Protection">Power Protection</a></li>

	<li class="itech-comm"><a href="http://software-monetization.tmcnet.com" title="Software Monetization">Software Monetization</a></li>
	
	<li class="itech-comm"><a href="http://www.transformingnetworkinfrastructure.com/" title="Transforming Network Infrastructure">Transforming Network Infrastructure</a></li>
	
</ul>
</div>
<div id="eNews">
	<a href="http://it.tmcnet.com/eNewsletterSignup.aspx" alt="InfoTech eNewsletter"><img src="https://images.tmcnet.com/tmc/it/images/it-enews.png" alt="Subscribe to the InfoTech eNewsletter" border="0" ></a>
</div>
<div id="skyscraper">
<!-- /1003160/120x600 -->
<div id='div-tmcmid' style='height:600px; width:120px; text-align:right'></div>
</div>
</div>
<!-- InfoTech Content -->
<div id="itech-content">
<!-- TMC1.ZZZ BEGIN -->

<div id="itech-middle">
                    <div id="it-subHead">
                        <h2>infoTECH Feature</h2>
                   	</div>
                    <!-- TMC.ZZZ SHARE -->
                    
<div align="right" style="padding-top:10px; padding-left:5px; float:right;">
<g:plusone size="small"></g:plusone>
<!-- Place this render call where appropriate -->
<script type="text/javascript">
  (function() {
    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
    po.src = 'https://apis.google.com/js/plusone.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
  })();
</script>
</div>
<div align="right" style="padding-top:10px; float:right;">
<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style addthis_16x16_style">
 <a class="addthis_button_facebook"></a>
    <a class="addthis_button_twitter"></a>
    <a class="addthis_button_google"></a>
     <a class="addthis_button_print"></a>
     <a class="addthis_button_email"></a>
</div>
<script type="text/javascript">var addthis_config = {"data_track_clickback":true};</script>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4da9ad3813b404b5"></script>

<!-- AddThis Button END -->
</div>
<div style="clear:right;"></div>
                    <div id="itech-editorial">
                         
                         
                        <div class="date"><!--ZZZDateZZZBEG-->July 24, 2020<!--ZZZDateZZZEND--></div>
                         
                        <h1>How Agencies Approach Software Development</h1>
                        <div class="paragraph"><img src="https://images.tmcnet.com/headshots/2012/tmcnet.jpg" height="59"> By <a class="pln-nav"><!--ZZZNameZZZBEG-->Special Guest<br><a>Anna Melnikova</a><!--ZZZNameZZZEND--></a></div>
                        <div><a class="date2"><!--ZZZATitleZZZBEG--><!--ZZZATitleZZZEND--></a></div>
                        <div class="story-article"><!--ZZZBodyZZZBEG--><p><img alt="" src="https://images.tmcnet.com/tmc/misc/articles/image/2020-jul/4816640335-bigstock-binary-stream-software-code-developer-tunnel-12115361-supersize.jpg" width="100%" /><br />
<br />
If you decide to outsource the development of the project, you must understand the specifics of this format of cooperation with the agency. You cannot fully control the &ldquo;inner kitchen&rdquo; of the project creation, will it be a startup or software for a large enterprise. But this is not necessary, as experienced agencies ensure the transparency and continuity of all work processes. They maintain constant communication with the client and resolve issues as they become available.</p>
<!--<div class="ad-hldr-tmc">

	<SCRIPT LANGUAGE=JavaScript>
	 
	 OAS_AD('Middle3');
 
	</SCRIPT>
				
</div>	-->









<p>Are you curious about what is happening behind the closed door of the company office? Then this article is for you. We will tell you all the intricacies of the software development process, which affects the speed of the team, how to avoid failures and complete the project before the deadline.</p>



<p><strong>Key Agency Activities During Software Development</strong></p>







<p>Software development is a time-consuming process that consists of a series of interrelated sequential steps. Each <a href="https://brights.io/">software development agency</a> has its methodology for solving tasks, but it is often guided by generally accepted <!--ZZZLinkBegZZZ-->Agile&nbsp;(<a href='http://www.tmcnet.com/snapshots/snapshots.aspx?Company=Agile'>News</a> - <a href='http://www.tmcnet.com/enews/subs.aspx?k1=%22Agile%22'>Alert</a>)<!--ZZZLinkEndZZZ--> principles.</p>



<p>Organization of work on each cycle of creating a software product includes the following steps:</p>



<p>1. <!--ZZZLinkBegZZZ-->Formation&nbsp;(<a href='http://www.tmcnet.com/snapshots/snapshots.aspx?Company=Formation'>News</a> - <a href='http://www.tmcnet.com/enews/subs.aspx?k1=%22Formation%22'>Alert</a>)<!--ZZZLinkEndZZZ--> of requirements. The project team determines the needs of the customer&rsquo;s business, the prospects for the project to scale. This analysis allows you to create a project concept, an idea of ??the main functional capabilities of future software.</p>



<p>2. Design and implementation. Agency specialists, based on the selected specification, accepted technical specifications, are engaged in the development of a software product.</p>



<p>3. Testing and validation. The team checks the created software for the quality of functioning in real operating conditions. At this stage, it is possible to adjust this or that option following the client&rsquo;s business objectives.</p>



<p>4. Technical support. The agency provides comprehensive technical support for software, adaptation, scaling of the project depending on changing market conditions or business tasks.</p>



<p><strong>Software Development Process: Step by Step</strong></p>



<p><img alt="" height="313" src="file:///C:/Users/TZACCA~1/AppData/Local/Temp/msohtmlclip1/01/clip_image002.jpg" /></p>



<p>The software development agency has a staff of specialists who provide tasks at each stage of the project life cycle. A team can go in two ways. The first of these is the traditional cascading method of software development, which provides for strict adherence to the stages of development.</p>



<p>The second way is a flexible development cycle (agile). It consists of small steps (sprints) that are repeated at each stage of work on a software product. This format is especially relevant when working on large projects, for which it is characteristic to make changes in the process of project implementation.</p>



<p>Consider the basic steps that makeup software development:&nbsp;</p>



<p>1. Planning</p>



<p>This is the preparatory phase, which includes the close interaction of the team under the supervision of the project manager with the customer. This is a kind of &ldquo;road map&rdquo; of the project, on which the success of the implementation of the tasks depends. Planning includes:</p>



<ul>
	<li>&nbsp;project team formation;</li>
</ul>



<ul>
	<li>&nbsp;preliminary structuring of work stages;</li>
</ul>



<ul>
	<li>&nbsp;valuation of material resources;</li>
</ul>



<ul>
	<li>&nbsp;coordination of cost, deadlines.</li>
</ul>



<p>Optimization of the workflow, the completion of tasks on time, directly depends on the strategic decisions that were made at the initial stage.</p>



<p>2. Business Requirements Assessment</p>



<p>A team of specialists must accurately understand the functional tasks of the software being developed. Otherwise, this can lead to fatal errors, for example, when the project does not meet the market conditions and user requests. Often customer requirements are blurred and not clearly defined. That is why agency experts hold briefings with business stakeholders. Based on a comprehensive analysis of the hidden and obvious needs of the business, the agency generates a documentary statement of the tasks and stages of software product development.</p>



<p>3. Software development&nbsp;</p>



<p>After the approval of the requirements, the agency&rsquo;s specialists begin to develop the physical architecture of the project. At this stage, architects can generate several quick prototypes to choose the most optimal solution by the tasks. When designing the architecture, weaknesses can be identified that require adjustments to the terms of reference. This set of measures can reduce the risk of errors in the functionality of the system in the future.</p>



<p>4. Programming</p>



<p>The software coding process depends on the methodology chosen. If the cascade model is taken as the basis, programming is carried out in one block. If a software development agency works on a flexible system, the process is divided into small cycles (sprints) that have time limits. At this stage, the team maintains constant communication with the client, reviews and reports on all stages.&nbsp;</p>



<p>5. Testing</p>



<p>The main objective of this cycle is to verify the functional characteristics of the developed software in real operating conditions. Experts evaluate in detail such parameters as code quality, performance, product security, and others. If bugs are detected during testing, the agency makes adjustments to the system code.</p>



<p>6. Deployment</p>



<p>Most experienced agencies use Jenkins to automate and speed up the software deployment process. This tool provides continuous software integration, preparation for an operation.</p>



<p>7. Maintenance</p>



<p>After the software is put into operation, the agency assumes the obligation to support the project. Specialists ensure the smooth operation of the system, quickly respond to inconsistencies that arise, and eliminate defects. They also advise the customer, staff on issues related to the functioning of the software product.</p>



<p><strong>Why does the delay of the software development occur?&nbsp;</strong></p>



<p>Software product development is a laborious process that requires a lot of time and human resources. Sometimes the deadlines for fulfilling tasks can be stretched like &ldquo;chewing gum&rdquo;, and this is largely a result of the incorrect organization of the work process.</p>







<p>The software development process may be delayed due to the following reasons:</p>



<ul>
	<li>&nbsp;the human factor: sick leave, holidays, low productivity due to lack of experience and knowledge to complete the task;</li>
</ul>



<ul>
	<li>&nbsp;customer uncertainty in their requirements, frequent task changes;</li>
</ul>



<ul>
	<li>&nbsp;problems with the material and technical base of the agency;</li>
</ul>



<ul>
	<li>&nbsp;incorrect estimation of the time that specialists need to develop a layout, prototype, etc;</li>
</ul>



<ul>
	<li>&nbsp;identifying bugs in project architecture;</li>
</ul>



<ul>
	<li>&nbsp;poorly established communication with the client at the stage of approval of a particular stage of work.</li>
</ul>



<p>Experienced software development agencies, when drawing up a plan and a schedule of work, take into account all possible risks in order to deliver the project on time precisely.</p>



<p><strong>Software Development Acceleration Techniques</strong></p>



<p>Time is one of the most valuable resources in the process of developing a software product. Mistakes can lead to fatal consequences, loss of time for specialists to correct them. That is why experienced agencies use different methods to automate the workflow and minimize the risk of defects.</p>



<p>These tools include:</p>



<ul>
	<li>&nbsp;continuous integration (CI) is a practice that allows you to detect and eliminate errors at an early stage of development due to the automatic assembly of different parts of the system into a single structure.</li>
</ul>



<ul>
	<li>&nbsp;source management - all development data is stored in a central repository. Thus, if there are problems with the file server, the code will not suffer.</li>
</ul>



<ul>
	<li>&nbsp;SDLC management tools are a set of practices that help professionals track errors, inconsistencies in the programming process, conduct analytics and manage tasks.</li>
</ul>


<br /><i></i><br /><!--ZZZBodyZZZEND--></div>
                        
                    </div>
                    <!-- TMC.ZZZ COMMENT -->         
            	</div>

 
<div id="itech-right">
<div style="margin-bottom:10px;">

<table width="100%" border="0" style="background-color:#000000;" cellspacing="0" cellpadding="0">
                      <tr>
					  						  <td width="20%" valign="middle" style="padding:3px 0px 0px 10px;" > 
						  
						  <!-- Place this tag in your head or just before your close body tag -->
<script type="text/javascript" src="http://apis.google.com/js/plusone.js"></script>

<!-- Place this tag where you want the +1 button to render -->
<g:plusone></g:plusone>
						  
						  </td>
                        <td width="60%" align="right"><strong style="font-size:12px; padding:0px 10px 0px 10px; font-family:Arial, Helvetica, sans-serif; font-weight:bold; color:#CCCCCC;">FOLLOW US</strong></td>

                        <td width="9%" valign="middle" style="padding-top:3px;"> <a href="https://twitter.com/InfoTechSpot" title="Twitter"><img src="https://images.tmcnet.com/tmc/satellite/images/twitter-icon.png" border="0" /> </a></td>
                        <td width="9%" valign="middle" style="padding-top:3px;"> <a href="http://www.facebook.com/pages/InfoTech-Spotlight/114733425220746" title="Facebook"> <img src="https://images.tmcnet.com/tmc/satellite/images/facebook-icon.png" border="0" /> </a></td>
                        <td width="9%" valign="middle" style="padding-top:3px;"> <a href="http://rss.tmcnet.com/rss/information%20technology" title="RSS"><img src="https://images.tmcnet.com/tmc/satellite/images/rss-icon.png" border="0" /> </a></td>
                      </tr>
                    </table>
                </div>


<div id="box336"> <!-- /1003160/300x250 -->
<div id='div-Middle' style='height:300px; width:250px;'></div> </div>

	<div id="box336">
	<h2>infoTECH Headlines</h2>
	<div class="wrp10">
	<span id="ITbucket">
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/07/24/446102-how-agencies-approach-software-development.htm' title="Information Technology - How Agencies Approach Software Development">How Agencies Approach Software Development</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/07/22/446081-technology-financial-retirement-planning.htm' title="Information Technology - Technology For Financial And Retirement Planning">Technology For Financial And Retirement Planning</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/07/22/446074-ciso-cdo-meeting-the-minds-data-security-key.htm' title="Information Technology - CISO and CDO Meeting of the Minds: Data Security is Key to Digital Transformation">CISO and CDO Meeting of the Minds: Data Security is Key to Digital Transformation</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/07/20/446061-understanding-internet-connection-options.htm' title="Information Technology - Understanding Your Internet Connection Options">Understanding Your Internet Connection Options</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/07/20/446051-why-ocr-technology-the-unsung-hero-data-driven.htm' title="Information Technology - Why OCR technology is the Unsung Hero of Data-Driven Businesses">Why OCR technology is the Unsung Hero of Data-Driven Businesses</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/07/13/445976-automation-that-matters-eliminates-errors.htm' title="Information Technology - Automation that Matters and Eliminates Errors">Automation that Matters and Eliminates Errors</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/07/07/445913-keeping-data-protected-businesses-the-middle-east-embark.htm' title="Information Technology - Keeping Data Protected as Businesses in the Middle East Embark on Remote Working Journey">Keeping Data Protected as Businesses in the Middle East Embark on Remote Working Journey</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/06/25/445805-with-best-intentions-intent-based-networking-improve-our.htm' title="Information Technology - With the Best of Intentions: Intent-Based Networking Can Improve Our Response to the COVID-19 Disruptions to Business">With the Best of Intentions: Intent-Based Networking Can Improve Our Response to the COVID-19 Disruptions to Business</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/06/10/445660-tips-buy-affordable-internet-connection.htm' title="Information Technology - Tips to Buy Affordable Internet Connection">Tips to Buy Affordable Internet Connection</a></h3>
		
		<h3><a href='http://it.tmcnet.com/topics/it/articles/2020/06/01/445560-hidden-technologybenefits-detecting-fake-ids-business.htm' title="Information Technology - Hidden TechnologyBenefits of Detecting Fake IDs for Business">Hidden TechnologyBenefits of Detecting Fake IDs for Business</a></h3>
		</span>
	</div>
	</div>

<form id="enewsform" name="enewsform" action="" method="post">
                <div style="margin-bottom:10px;">

                    <table width="100%" border="0" style="background-color:#171717;" cellspacing="0" cellpadding="0">
                     <tr>
                        <td colspan="3"><div class="pg-wrp10">
                        <div class="enews-lft">
						<a href='http://it.tmcnet.com/eNewsletterSignup.aspx'>
						<img src="https://images.tmcnet.com/tmc/vertical/robotics/images/enews_signup.png" width="60" border="0" /></a>
						
						</div>
                        <div class="enews-rt"><h4>Subscribe to InfoTECH Spotlight eNews</h4>
                       InfoTECH Spotlight eNews delivers the latest news impacting technology in the IT industry each week. Sign up to receive FREE breaking news today!
                        </div>
                        <div class="magic"></div>
                        </div></td>
                      </tr>
                      <tr>
                        <td width="35%">
                          <strong style="font-size:11px; padding:0px 0px 0px 10px; font-family:Arial, Helvetica, sans-serif; font-weight:bold; color:#CCCCCC;">FREE eNewsletter</strong>                        </td>
                        <td width="45%" valign="middle">
                          <input id="txtEmail" value="Type your email here " style="font-size: 12px; width:140px;" onfocus="this.value='';"
                            type="text" />                        </td>

                        <td width="20%" valign="middle" style="padding:3px 2px 0px 0px;">
                          <a onclick="javascript:gotoENewsletter()" onmouseover="this.style.cursor='hand';">
                            <img id="btnSubmit" src="https://images.tmcnet.com/tmc/vertical/it/images/it_submitt_butt.gif" />                          </a>                        </td>
                      </tr>
                    </table>
                </div>
                </form>	
	
	
                    <div class="top-news-nav-hldr">
                        <div id="bucket5Link" class="navOn"><a href="javascript:showBucket2('bucket5')">Blogs</a></div> 
                        <div id="bucket6Link" class="navOff"><a href="javascript:showBucket2('bucket6')">Videos</a></div>
                        <div id="bucket7Link" class="navOff"><a href="javascript:showBucket2('bucket7')">Webinars</a></div>
                    </div>
                    
                    <div id="bucket5">
                    <span id="rtBlog">
                        <div class="blog"><a href="https://blog.tmcnet.com/blog/rich-tehrani/sd-wan/aryaka-adds-managed-security-to-sd-wan-naas-offering-with-check-point-relationship.html" target="_blank">Aryaka adds Managed Security to SD-WAN, NaaS Offering with Check Point Relationship</a></asp:HyperLink><br />Rich Tehrani</div> 
                        
                        <div class="blog"><a href="https://blog.tmcnet.com/blog/rich-tehrani/technology/ivanti-and-intel-partner-to-offer-self-healing-of-remote-worker-endpoints.html" target="_blank">Ivanti and Intel Partner to Offer Self-Healing of Remote Worker Endpoints</a></asp:HyperLink><br />Rich Tehrani</div> 
                        
                        <div class="blog"><a href="https://blog.tmcnet.com/blog/rich-tehrani/sd-wan/secure-sd-wan-addresses-organizations-secure-connectivity-needs-with-everyone-working-from-home.html" target="_blank">Secure SD-WAN Addresses Organizations' Secure Connectivity Needs with Everyone Working from Home</a></asp:HyperLink><br />Rich Tehrani</div> 
                        
                        <div class="blog"><a href="https://blog.tmcnet.com/blog/rich-tehrani/unified-communications/vyopta-launches-support-for-microsoft-teams.html" target="_blank">Vyopta Launches Support for Microsoft Teams</a></asp:HyperLink><br />Rich Tehrani</div> 
                        
                        <div class="blog"><a href="https://blog.tmcnet.com/blog/rich-tehrani/crm/customer-intelligence-platform-zeotap-grows-431-raises-oversubscribed-series-c-at-42m.html" target="_blank">Customer Intelligence Platform Zeotap Grows 431%, Raises Oversubscribed Series C at $42M</a></asp:HyperLink><br />Rich Tehrani</div> 
                        </span>
                   
					</div>
                    
                    <div id="bucket6" style="display: none;">
                    <span id="ITVideos">
                            <div class="video"><a href='http://www.tmcnet.com/tmc/videos/default.aspx?vid=12347&type=3&title=ConnectLeaderConnectLeader' title="ConnectLeader" target="_blank">ConnectLeader</a><br />Rich Tehrani speaks with Jim Lochry of ConnectLeader</div>
                        
                            <div class="video"><a href='http://www.tmcnet.com/tmc/videos/default.aspx?vid=12346&type=3&title=ConnectLeaderConnectLeader' title="ConnectLeader" target="_blank">ConnectLeader</a><br />Rich Tehrani speaks with Jim Lochry of ConnectLeader</div>
                        
                            <div class="video"><a href='http://www.tmcnet.com/tmc/videos/default.aspx?vid=12289&type=3&title=XKL at TEX 2016XKL at TEX 2016' title="XKL at TEX 2016" target="_blank">XKL at TEX 2016</a><br />TMC&#39;s Rich Tehrani speaks with Colleen Gallagher of XKL at TEX 2016</div>
                        
                            <div class="video"><a href='http://www.tmcnet.com/tmc/videos/default.aspx?vid=12288&type=3&title=Richard McFarland of Voice4NetRichard McFarland of Voice4Net at Real Time Web Solutions 2016' title="Richard McFarland of Voice4Net at Real Time Web Solutions 2016" target="_blank">Richard McFarland of Voice4Net at Real Time Web Solutions 2016</a><br />Richard McFarland of Voice4Net talks WebRTC at Real Time Web Solutions NYC 2016</div>
                        
                            <div class="video"><a href='http://www.tmcnet.com/tmc/videos/default.aspx?vid=12287&type=3&title=Bent Rye of Temasys at Real TiBent Rye of Temasys at Real Time Web Solutions 2016' title="Bent Rye of Temasys at Real Time Web Solutions 2016" target="_blank">Bent Rye of Temasys at Real Time Web Solutions 2016</a><br />Bent Rye of Temasys talks WebRTC at Real Time Web Solutions NYC 2016</div>
                        </span>
                    </div>

                     <div id="bucket7" style="display: none;">
                    <span id="ITWebinars"></span>
                    </div>

	<div id="box336">
	<h2>infoTECH Whitepapers</h2>
	<div class="wrp10">
	<span id="ITwps"></span>
	</div>
	</div>
	
<div id="ad-box">
<!-- /1003160/300x250 -->
<div id='div-MiddleR2' style='height:300px; width:250px;'></div>
	</div>

<div id="box336">
<h2>What is Information Tehnology </h2>
<div class="wrp10">
<ul id="news-list-ftr">
<div style="float:right"> <img src="https://images.tmcnet.com/tmc/vertical/it/images/info_tech_rsc.jpg" width="90" style="border:1px solid #666;" /></div>
<li><a href='http://it.tmcnet.com/topics/it/articles/164791-what-information-technology.htm' title="What is Information Technology?">What is Information Technology?</a></li>
<li><a href='http://it.tmcnet.com/topics/it/articles/164702-history-information-technology.htm' title="The History of Information Technology">The History of Information Technology</a></li>
<li><a href='http://it.tmcnet.com/topics/it/articles/164701-todays-most-desired-information-technology-skills.htm' title="Today's Most Desired Information Technology Skills">Today's Most Desired Information Technology Skills</a></li>
<li><a href='http://it.tmcnet.com/topics/it/articles/164704-information-technology-careers.htm' title="Information Technology Careers">Information Technology Careers</a></li>
<li><a href='http://it.tmcnet.com/topics/it/articles/164765-ten-information-technology-companies-2011.htm' title="Ten Information Technology Companies of 2011">Ten Information Technology Companies of 2011</a></li>
          
 </ul>
                    
				  </div>
               	  </div>
					   
</div>

<div class="magic"></div>
</div>
<div class="magic"></div>
</div>
<!-- IT Footer -->
<!-- IT Footer -->
<div id="it-footer">
	<div id="footerFloat">
	<div class="footerTitle">Powered by</div>
	
	  <div><a href="http://www.tmcnet.com/" title="TMCnet.com"><img src="https://images.tmcnet.com/tmc/it/images/TMCnetcom.png" alt="TMCnet.com" border="0" /></a></div>
		<div class="footerText">
		Technology Marketing Corporation,
		<br />
		2 Trap Falls Road Suite 106, Shelton, CT 06484 USA
		<br />
		Ph: 800-243-6002, 203-852-6800; <br />
		<br />
		<a href="http://it.tmcnet.com/Contact.aspx" target="_blank" title="Contact TMC">Contact us</a>
		<br />
 &copy; Technology Marketing Corp.
		</div>
	</div>
				
	<div id="footerFloat">
		<div class="footerTitle">infoTECH Resources</div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/FeaturedArticles.aspx" title="Information Technology Feature Editorial">Editor's Pick</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/magazine/" title="Information Technology Magazine">Magazine</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/topnews.aspx" title="Information Technology News">infoTECH News</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/itsoftware.aspx" title="Information Technology Software">Software News</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/ithardware.aspx" title="Information Technology Hardware">Hardware News</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/itsecurity.aspx" title="Information Technology Security">Security News</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/itnetworking.aspx" title="Information Technology Networking">Networking News</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/Library.aspx" title="Information Technology Whitepapers">Whitepapers</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/Library.aspx?type=podcasts" title="Information Technology Podcasts">Podcasts</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/Videos.aspx" title="Information Technology Videos">Videos</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/webinars.aspx" title="Information Technology Webinars">Webinars</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/blogs.aspx" title="Information Technology Blogs">Blogs</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/Services.aspx" title="Information Technology Services">Services</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/Awards.aspx" title="Satellite Spotlight Awards">Awards</a></div>
		<div class="fit-resource"><a href="http://it.tmcnet.com/whatshot.aspx" title="What's Hot in Information Technology">What's Hot</a></div>
		<div class="fit-resource"><a href="https://images.tmcnet.com/mkt/media-kit/InfoTECH-Spotlight_Media-Kit.pdf" title="infoTECH Spotlight Media Kit" target="_blank">Media Kit</a></div>
	</div>
				
	<div id="footerFloat">
		<div class="footerTitle">infoTECH Communities</div>
 
<div class="fit-resource"><a href="http://call-recording.tmcnet.com/" title="Call Recording">Call Recording </a></div>
<div class="fit-resource"><a href="http://sip-trunking.tmcnet.com/" title="SIP Trunking">SIP Trunking </a></div>
<div class="fit-resource"><a href="http://unified-communications.tmcnet.com/" title="Unified Communications">Unified Communications </a></div>
<div class="fit-resource"><a href="http://www.sdwanresource.com/" target="_blank" title="SD-WAN">SD-WAN  </a></div>
<div class="fit-resource"><a href="http://www.advancedaudioconferencing.com/" target="_blank" title="Audio Conferencing">Audio Conferencing </a></div>
	</div>
				
	<div id="footerFloat">
		<div class="footerTitle">infoTECH Channels</div>
	 	 
		 
		<div class="fit-resource"><a href="http://www.powerprotectionresource.com/" title="Power Protection">Power Protection</a></div>
		<div class="fit-resource"><a href="http://www.softwarelicensingreport.com/" title="Software Licensing">Software Licensing</a></div>
		<div class="fit-resource"><a href="http://software-monetization.tmcnet.com" title="Software Monetization">Software Monetization</a></div>
		<div class="fit-resource"><a href="http://www.tmcnet.com/channels/virtual-pbx/" title="Virtual PBX">Virtual PBX</a></div>
		<div class="fit-resource"><a href="http://www.tmcnet.com/channels/workforcemanagementtoday/" title="Workforce Management">Workforce Management </a></div>

		
		


	</div>
	
	<div id="footerFloat">
		<div class="footerTitle">Other Industries</div>
		<div class="fit-resource"><a href="http://www.tmcnet.com/" title="IP Communications" target="_blank">IP Communications</a></div>
		<div class="fit-resource"><a href="http://www.cablespotlight.com/" title="Satellite Technology" target="_blank">Cable Spotlight</a></div>
		<div class="fit-resource"><a href="http://www.satellitespotlight.com/" title="Satellite Technology" target="_blank">Satellite Spotlight</a></div>
		<div class="fit-resource"><a href="http://www.mobilitytechzone.com/" title="MobilityTechzone" target="_blank">MobilityTechzone </a></div>
		<div class="fit-resource"><a href="http://smart-grid.tmcnet.com/" title="Smart Grid" target="_blank">Smart Grid</a></div>
		<div class="fit-resource"><a href="http://www.sportstechy.com/" title="Sports Techy: Sports Technology & Communications" target="_blank">Sports Techy</a></div>
		<div class="fit-resource"><a href="http://www.m2mevolution.com/" title="M2M Evolution" target="_blank">M2M Evolution</a></div>
	</div>
	<div class="magic"></div>     
</div>

<!-- Start Quantcast tag - ->
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<script type="text/javascript">_qacct="p-5cEhFSZZan1sk";quantserve();</script>
<noscript>
<a href="http://www.quantcast.com/p-5cEhFSZZan1sk" target="_blank"><img src="http://pixel.quantserve.com/pixel/p-5cEhFSZZan1sk.gif" style="display: none" border="0" height="1" width="1" alt="Quantcast"/></a>
</noscript>
<!-- End Quantcast tag -->


<div align="center">
	<script language="javascript">
	<!--
	    OAS_AD('x50');
	//-->
	</script>
</div>
<!-- Start Quantcast tag -->
<script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script>
<script type="text/javascript">_qacct="p-5cEhFSZZan1sk";quantserve();</script>
<noscript>
<a href="http://www.quantcast.com/p-5cEhFSZZan1sk" target="_blank"><img src="http://pixel.quantserve.com/pixel/p-5cEhFSZZan1sk.gif" style="display: none" border="0" height="1" width="1" alt="Quantcast"/></a>
</noscript>
<!-- End Quantcast tag -->


<!-- Google Code for Remarketing Tag -->
<script type="text/javascript">
/* <![CDATA[ */
var google_conversion_id = 1072705670;
var google_conversion_label = "DPedCK6-9FgQhuHA_wM";
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */
</script>
<script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js">
</script>
<noscript>
<div style="display:inline;">
<img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/1072705670/?value=1.00&amp;currency_code=USD&amp;label=DPedCK6-9FgQhuHA_wM&amp;guid=ON&amp;script=0"/>
</div>
</noscript>


</div>
</div>
</body>
</html>


